Issue
Your Salesforce Organization was refreshed and after this process, when log in to dataloader.io the subscription and your tasks are lost.
Cause
When the Organization is refreshed is like starting from a brand new Organization with new a Org ID and every user in your Org will get also new Salesforce IDs. As consequence of this change, next time you log in to dataloader.io a new account will be generated since your user with a new ID won't be associated to the old user.
As consequence you will have a new dataloader.io account without any task or subscription.
Solution
In case you are under the situation explained above, the solution on dataloader.io side is to request a subscription migration. Check the following article for instructions and other relevant information regarding this process: Transfer an Existing Subscription to Another User.
Note: Tasks cannot be migrated. In case you have tasks that you don't want to lose, then the only alternative is to get the old Organization back with the old Salesforce ID for your User. In case you can get this back, when you log in to dataloader.io with that account you will be logged in to the old dataloader.io account.
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