Object or Field is not visible from dataloader.io

Issue

You created a task and you don't see a particular object or field when setting the mapping or selecting the fields to export.

Cause

There are two possible causes for this issue:

  1. Missing permissions.
  2. The object/field has been introduced in Salesforce v38 or later.

Solution

If you are unable to find a certain object or a field of an object in the dataloader.io UI, you'll need to verify that you have appropriate permissions over the offending object.

As a rule of thumb, any users that need to import data into a specific object/field, need to have the "write" access enabled for that entity while exporting needs "read" access.

Unfortunately, if the cause is that object/field was introduced in Salesforce v38 or later then dataloader.io won't support it for the time being.

You can validate in the Salesforce SOAP API Developer Guide if the object/field is listed for v37. In case you are not able to find it in v37 (and you can in newer versions) then that object is not supported.

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