ISSUE
Suddenly your tasks start failing with an error message similar to the one below.
There is no access token stored under the key https://login.salesforce.com/id/00D6g000001V6goEAC/0056g000001FCbFAAW . You need to call the message processor. The key will be given to you via a flow variable after the OAuth dance is completed. You can extract it using flowVars['tokenId'].
CAUSE
This error is caused by a session expiration on a secondary connection that is being used for running the tasks that are failing with that error.
SOLUTION
Please, re-create the connection (without deleting it) following these steps:
- Click on your username in the top right corner > Settings.
- Go to the Connections tab.
- Click on NEW CONNECTION > SALESFORCE.
- Enter the account details to log in so the connection is created.
Those steps will refresh the session for that already created connection and the error should be gone.
NOTE: If you don't delete the connection this procedure won't have any impact on your tasks and the issue will be fixed. In case you delete the connection, as the alert popping up explains, any task related to that secondary connection will be deleted.
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